XFCE 4.10 for siduction


As Debian will not ship XFCE 4.10 in unstable until after Wheezy was released and this is very unlikely to happen before spring 2013, (460 RC-Bugs to fix) we decided that we want XFCE 4.10 now for our users. Parts of it are suffering bitrot in experimental, others needed to be packaged still.

We are happy to let our XFCE users update their installations now (thanks to agaida and towo). All you need to do is, as root:

echo deb http://ftp.spline.de/pub/siduction/xfcenext unstable main \
     > /etc/apt/sources.list.d/xfcenext.list

That will put a file called xfcenext.list into your sources.list.d folder and write the appropriate line to it. Then you can install or update an existing XFCE with:

apt-get update && apt-get install xfce4

The repository itself can be  found on our repository listing for amd64 or i386

Have fun with your shiny new XFCE.

4 thoughts on “XFCE 4.10 for siduction

  1. Vitaly Rodionov

    Hello,
    I am getting an error:
    The following packages have unmet dependencies:
    xfce4 : Depends: xfwm4 (>= 4.10.0) but 4.6.2-1 is to be installed
    Depends: xfconf (>= 4.10.0) but 4.6.2-1 is to be installed
    Depends: xfce4-settings (>= 4.10.0) but 4.6.5-2 is to be installed
    Depends: xfce4-panel (>= 4.10.0) but 4.6.4-1 is to be installed
    Depends: xfdesktop4 (>= 4.10.0) but it is not going to be installed
    Depends: thunar (>= 1.4.0) but it is not going to be installed
    Depends: gtk2-engines-xfce (>= 3.0.0) but 2.6.0-2 is to be installed
    Depends: xfce4-session (>= 4.10.0) but 4.6.2-3 is to be installed
    Depends: xfce4-appfinder (>= 4.10.0) but 4.6.2-1 is to be installed
    Depends: xfce4-mixer (>= 4.8.0) but 4.6.1-2+b1 is to be installed
    Depends: orage (>= 4.8.0) but 4.6.1-1+b1 is to be installed
    Depends: libxfce4ui-utils (>= 4.10) but it is not going to be installed
    Recommends: thunar-volman (>= 0.8.0) but it is not going to be installed
    E: Broken packages

    Are there any additional steps I have to do before installation?
    Thanks,
    Vitaly

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *